librosa安装常见错误

时间: 2023-07-11 admin 互联网

librosa安装常见错误

librosa安装常见错误

librosa安装过程中最常见的问题就是
numba llvmlite已经存在,无法更新,解决办法:

  conda install --channel=numba llvmlite

然后安装librosa

       pip install librosa

librosa 0.7版本支持python2.7环境,后续的版本就要求python3的环境。

使用命令pip install librosa==0.7.0直接安装的话,会要求依赖包numba>=0.38.0

但是实际运行的话会安装numba 0.47,而numba 0.47会要求llvmlite版本是0.32,但是llvmlite 0.32是不支持python 2.7版本的。
————————————————
版权声明:本文为CSDN博主「boyStray」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接: